Close

Results 1 to 5 of 5

Thread: Stiff steering

  1. #1
    Registered User
    Join Date
    Nov 2019
    Location
    FLORIDA
    Posts
    2

    Stiff steering

    Hi,


    I have an 03 Civic SI i recently purchased with 62k miles. Since i bought the car I have replaced several things such as the tie rods struts and springs and so on. however since i have owned the car the steering has been fairly stiff regardless of speed. I dont feel any clunks or hear any noises coming from the rack. In order to keep it straight on the highway i have to have a firm grip on it. Do you think this is simply the motor or is the whole rack toast and im better of buying the whole thing. Let me know if anyone is experiencing anything similar. I have seen the motors online for around $75-$100 for used units and have been tempted to give it a try.

    PS i was also thinking that the ball joints may be the cause of this so any thoughts on that would be helpful.

  2. #2
    Registered User
    Join Date
    May 2019
    Location
    California
    Posts
    23
    Quote Originally Posted by ChrisL333 View Post
    Hi,


    I have an 03 Civic SI i recently purchased with 62k miles. Since i bought the car I have replaced several things such as the tie rods struts and springs and so on. however since i have owned the car the steering has been fairly stiff regardless of speed. I dont feel any clunks or hear any noises coming from the rack. In order to keep it straight on the highway i have to have a firm grip on it. Do you think this is simply the motor or is the whole rack toast and im better of buying the whole thing. Let me know if anyone is experiencing anything similar. I have seen the motors online for around $75-$100 for used units and have been tempted to give it a try.

    PS i was also thinking that the ball joints may be the cause of this so any thoughts on that would be helpful.

    mine does the same thing it stuck to the right after i turn it left all the way then put it straigt it aligns perfect but ive messed with the middle of the tie rods pushed it around and its worked for a while

  3. #3
    Registered User
    Join Date
    Nov 2019
    Location
    Philadelphia
    Posts
    1
    your talking about the power steering. the faster you go the easier it is suppose to get even without power steering. It could be more then one issue. needs an alignment and bad ball Joints with the steering rack. But I would change that motor first.

  4. #4
    Registered User
    Join Date
    Nov 2019
    Location
    FLORIDA
    Posts
    2
    Hi Holly,

    I have changed the front struts and outer tie rods. The only thing left is the ball joints as far as a joint that could affec tthis. I have had an alignment as well since the work was done. The power steering does work however it is inconsistent. and especially at high speeds it is not comfortably turnable with one hand.

  5. #5
    Registered User
    Join Date
    Feb 2017
    Location
    Ga
    Posts
    59
    Any signs of a shunt? I would check the steering arms.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •