Close

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jun 2020
    Location
    California
    Posts
    1

    Iím stumped please help

    So I bought an 04 Si a while back. Started to have starter issues where it wouldnít crank over when I turned the key. The starter finally took a dump and the battery with it. So I spent three days getting the new starter in and a new battery. Then when I went to go start it, the engine still wonít crank over. Checked the fuses under the hood and everything looked good. Went to Honda stealership and got a new starter cut relay thinking it might be that. Still no cranking at all. Lights work and the green key light goes out like normal. So now Iím thinking, since I changed the battery is there maybe a security system lockout or something similar? I donít believe I have an aftermarket alarm on the car. Any ideas would be greatly appreciated, sorry if Iím in The wrong forum.

  2. #2
    Registered User
    Join Date
    May 2019
    Location
    Dallas, Tx
    Posts
    5
    Here is something to check. So, Iíve been in your predicament before with my EP3. Car wouldnít start. Wouldnít crank, no clicking noise. I happen to be stuck near an auto store and they were only able to check battery, but no issues. Was able to push my car and pop the clutch to get it started. Got home and wouldnít start up. I had replaced the battery and alternator several months before so my guess was the starter. Took it off and had auto store check it, no issues with it. Long story short....it was the clutch pedal switch (or clutch safety switch). Whatever it may be called, it is a switch at the top of the clutch pedal that gets pressed-in to allow the car to start. You can test by pushing the switch in with your finger and starting your car. Make sure you are in neutral before you do this. Sometimes it will not get pressed-in enough. I ended up just disabling mine.

    If that doesnít work, it was just one more thing to check off your list.
    Last edited by ZephyrElite; 06-17-2020 at 04:50 PM. Reason: Stated wrong info

  3. #3
    Don't think too hard 2004ep3hatch's Avatar
    Join Date
    Jul 2004
    Location
    Retardville P.A
    Posts
    1,580
    Quote Originally Posted by Thecarguy View Post
    So I bought an 04 Si a while back. Started to have starter issues where it wouldn’t crank over when I turned the key. The starter finally took a dump and the battery with it. So I spent three days getting the new starter in and a new battery. Then when I went to go start it, the engine still won’t crank over. Checked the fuses under the hood and everything looked good. Went to Honda stealership and got a new starter cut relay thinking it might be that. Still no cranking at all. Lights work and the green key light goes out like normal. So now I’m thinking, since I changed the battery is there maybe a security system lockout or something similar? I don’t believe I have an aftermarket alarm on the car. Any ideas would be greatly appreciated, sorry if I’m in The wrong forum.
    What kind of starter did you buy? Was it aftermarket?
    Supercharged K24 Frank powered
    PM a Moderator for assistance anytime

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •